An error has occurred while validating the configuration settings

The error is There are a few results returned searching for a solution to this problem (including several pages on Stack Overflow) and they pretty much all boil down to the one suggestion of adding or setting a value of 0 for Enable Out Of Proc Build to the key HKEY_CURRENT_USER\Software\Microsoft\Visual Studio.0_Config\MSBuild We followed this advice and, while it allowed us to build the setup projects from a command line on the build machine, it hasn't helped with the team build.

Note, we've tried adding the registry setting in various places but none have helped.

But build-servers often use other accounts (Local System and so on).

connect issue That error didn't stop me from deploying, building, debugging (or anyting) my project it just annoyed me.

I first set the key to 64-bit DWORD and it did not fix the build error 8000000A.

I have been receiving this error for a while when using devenv on an automatic build.

I have gone through every website I can find, and the usual answers mention refreshing dependencies (Which I believe fixes it for manual deployment, but not for automatic) and removing the source control coding from the projects, which hasn't helped me.

The error does not occur every time I build, but it seems random on different deployment projects each time.

Search for an error has occurred while validating the configuration settings:

an error has occurred while validating the configuration settings-30

Leave a Reply

Your email address will not be published. Required fields are marked *

One thought on “an error has occurred while validating the configuration settings”